[ImageJ-devel] Maven problem

Tobias Pietzsch pietzsch at mpi-cbg.de
Fri Apr 11 07:27:05 CDT 2014

Hi Steffi,

Projector2D has been replaced by IterableIntervalProjector2D recently in imglib2 core.
Apparently the version of imglib2 core you have is more recent than 2.0.0-beta-25, because that one doesn't have this change yet.
However, your imglib-ij project probably is build against the beta-25 and thinks Projector2D is still there.
(I'm really not looking forward to the world of split imglib repositories, I fear we'll see a lot of problems like this…)

Instead of overriding individually the version of imglib2, I would recommend just setting the version property in your pom to


Then in the actual dependencies don't give any version:


and it should pick the managed one which is now 2.0.0-SNAPSHOT.

Could you try this?

best regards,

On Apr 11, 2014, at 10:16 AM, Stephan Preibisch <preibischs at janelia.hhmi.org> wrote:

> Hi,
> Christian helped me, I changed the version of ImgLib2 to ${imglib2.version}, now it works. 
> But Eclipse doesn't recognize the opened project anymore (see screenshot). It also complains that "Overriding managed version 2.0.0-beta-25 for imglib2", no idea what that means.
> Again, any help would be great.
> Thanks a lot,
> Steffi
> <Screen.jpeg>
> On Apr 11, 2014, at 17:53 , Stephan Preibisch wrote:
>> Hi guys,
>> I am almost there with the new spimreconstruction branch (https://github.com/fiji/spimreconstruction/tree/newspimreconstruction), and I re-implemented the first fusion in ImgLib2. Now I run into the problem that a simple
>> ImageJFunctions.show( ArrayImgs.floats( new long[]{ 300, 100, 200} ) );
>> fails with:
>> Exception in thread "main" java.lang.NoClassDefFoundError: net/imglib2/display/projector/Projector2D
>> 	at net.imglib2.img.display.imagej.ImageJVirtualStack.<init>(ImageJVirtualStack.java:93)
>> 	at net.imglib2.img.display.imagej.ImageJVirtualStackFloat.<init>(ImageJVirtualStackFloat.java:51)
>> 	at net.imglib2.img.display.imagej.ImageJFunctions.wrapFloat(ImageJFunctions.java:238)
>> 	at net.imglib2.img.display.imagej.ImageJFunctions.wrap(ImageJFunctions.java:170)
>> 	at net.imglib2.img.display.imagej.ImageJFunctions.show(ImageJFunctions.java:219)
>> 	at net.imglib2.img.display.imagej.ImageJFunctions.show(ImageJFunctions.java:123)
>> 	at spim.fiji.plugin.Image_Fusion.run(Image_Fusion.java:40)
>> 	at spim.fiji.plugin.Image_Fusion.main(Image_Fusion.java:104)
>> Caused by: java.lang.ClassNotFoundException: net.imglib2.display.projector.Projector2D
>> 	at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
>> 	at java.security.AccessController.doPrivileged(Native Method)
>> 	at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
>> 	at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
>> 	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
>> 	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
>> 	... 8 more
>> I have all imglib projects checked out, up-to-date and maven depencies updated.
>> If anyone has any idea where this comes from would be great!
>> Thanks so much,
>> Steffi
>> _______________________________________________
>> ImageJ-devel mailing list
>> ImageJ-devel at imagej.net
>> http://imagej.net/mailman/listinfo/imagej-devel
> _______________________________________________
> ImageJ-devel mailing list
> ImageJ-devel at imagej.net
> http://imagej.net/mailman/listinfo/imagej-devel

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://imagej.net/pipermail/imagej-devel/attachments/20140411/1df8f6bb/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 455 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <http://imagej.net/pipermail/imagej-devel/attachments/20140411/1df8f6bb/attachment.pgp>

More information about the ImageJ-devel mailing list