[ImageJ-devel] Naming [was: Re: [fiji-devel] RegionOfInterestCursor considered misnamed]

Stephan Saalfeld saalfeld at mpi-cbg.de
Mon Oct 11 15:17:51 CDT 2010


> I vote for interface "Tensor".
> The misnamed "imglib" is a tensor lib.
> From http://en.wikipedia.org/wiki/Tensor :
> "... tensors in general can be considered as a multidimensional array
> of numbers"

... which is true for only the most basic concepts to be expressed by
the intended interface `Image'.  Already a sparsely sampled space is not
a tensor any more, neither is a 3d-scene description or a
hyper-spherical mask (actually anything that is not a box and discrete).
Yes, you can sample these Images in a discrete raster but you don't have
to.  Positionables in real space (Interpolators) are the most trivial
example.  The Iterator already does it's own magic.

The true meaning of the interface Image is that it spans and limits a
function-space or domain, so we could call it `Function', `Space' or
`Domain', great for math-agnostic developers learning the API (though
not as horrible as LocalizableByDimCursor ;)).  `Tensors' could then be
a sub-interface that guarantees that the samples are on a discrete
regular grid of a box.

I completely agree that it sucks to collide with java.awt.Image.
Besides, I am quite sure that, in the global Java namespace, there is
little room for non-colliding names except we call it a silly name.  I
am pro:

Img (favorite), Domain (promising collisions), Space, Scene, Function
(best choice but promising collisions and missleading expectations).

The most recent developments are tracked in the branch sampler-link
(which stems from sampler but got rid of the links...) where development
was recently stopped for too long time by the silly CellContainer bug
that came from master but I was searching in the changes...


> Albert

More information about the ImageJ-devel mailing list