[ImageJ-devel] Naming [was: Re: [fiji-devel] RegionOfInterestCursor considered misnamed]

Albert Cardona sapristi at gmail.com
Mon Oct 11 12:51:23 CDT 2010

> I don't really like it either. How about "Img" mirroring the "img" in
> "imglib"? Kind of ugly but at least it's unique. Otherwise we could use
> "IImage" or "NDImage" or "ILImage" or "HyperImage"...

I vote for interface "Tensor".

The misnamed "imglib" is a tensor lib.

>From http://en.wikipedia.org/wiki/Tensor :

"... tensors in general can be considered as a multidimensional array
of numbers"


More information about the ImageJ-devel mailing list