[ImageJ-devel] Naming [was: Re: [fiji-devel] RegionOfInterestCursor considered misnamed]

Johannes Schindelin Johannes.Schindelin at gmx.de
Mon Oct 11 12:32:37 CDT 2010


On Mon, 11 Oct 2010, Curtis Rueden wrote:

> I agree with Grant. If the design is going to change and break existing 
> code—which I think is fine at this stage—I would like to see a different 
> name than "Image" to avoid clashing with java.awt.Image.

Yes, I agree that nomenclature might be something we want to change, 

> > "MultidimensionalImageDataBufferLikeThingThatIsNotReallyAnImage" ??

... Grant, you're not German enough to be entitled to suggest such a 
variable name :-)

I do not like ImageSpace, though. It contradicts my perception of what the 
class is about.

After thinking about this, I am not really sure that I want to change the 
name "Image", though. You should not use java.awt.Image and 
mpicbg.imglib.image.Image in the same class to begin with.

And in a sense, they _do_ mean the same. It's just that AWT is limited to 
2 dimensions, why imglib isn't.

There are other class names I'd love to see changed, but "Image" is not 
one of them.


More information about the ImageJ-devel mailing list