[ImageJ-devel] [Bug 739] Bug in the Threshold / Color Threshold

bugzilla at fiji.sc bugzilla at fiji.sc
Sat May 3 11:18:58 CDT 2014


G. Landini <g.landini at bham.ac.uk> changed:

           What    |Removed                     |Added
             Status|NEW                         |RESOLVED
         Resolution|---                         |INVALID

--- Comment #4 from G. Landini <g.landini at bham.ac.uk> ---
I think that there are 2 issues here.

1) The macro you uploaded produces a binary image. I am almost sure that is the
automatically generated macro by the Colour Threshold plugin except the first
line and the last line.

You uploaded a very faint RGB image as the "expected result".
If I run the macro, I get a whole black image and the result is, I believe,
what is expected as it stops the Brightness values between 87 and 255. Since
the image you provided has no "black" (i.e. Brightness <87), the thresholding
will find no pixels and the result is all black (as expected, i.e. no black
regions that should appear white).

2) If the macro were to "delete" black areas, the code should do something more
with the regions found to be black (i.e. "white" after running the macro).
Are you sure that you have not deleted part of it?

I think that to delete black regions perhaps the result of the thresholding
should be added to the original image, but this is me just guessing.

I do not see any bug in the code in ImageJ1 and the macro as is produces the
same result in IJ1 and Fiji.

I will resolve this as "invalid" bug. Please reopen this bug if you can provide
the examples suggested above where the same image produces different results in
different platforms.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://imagej.net/pipermail/imagej-devel/attachments/20140503/05cebe45/attachment-0001.html>

More information about the ImageJ-devel mailing list