Difference between revisions of "Talk:PlugIn Design Guidelines"

(obsolete info?)
 
 
Line 1: Line 1:
 
isnt much of this obsoleted in imageJ2, in that the script editor can no onger compile and run .java????
 
isnt much of this obsoleted in imageJ2, in that the script editor can no onger compile and run .java????
 +
 +
 +
Yeah, there is a mix of still-relevant, and now-obsolete information. Note that the Script Editor still ''can'' compile and run Java code. But we are really phasing out usage of the Fiji/ImageJ launcher to do that stuff, in favor of properly structured Maven projects (which the Script Editor can actually generate for you...). Anyway, for now I just slapped the Outdated template on it as a warning. [[User:Rueden|Rueden]] ([[User talk:Rueden|talk]])

Latest revision as of 11:23, 19 October 2015

isnt much of this obsoleted in imageJ2, in that the script editor can no onger compile and run .java????


Yeah, there is a mix of still-relevant, and now-obsolete information. Note that the Script Editor still can compile and run Java code. But we are really phasing out usage of the Fiji/ImageJ launcher to do that stuff, in favor of properly structured Maven projects (which the Script Editor can actually generate for you...). Anyway, for now I just slapped the Outdated template on it as a warning. Rueden (talk)