Hi Dscho,<br><br><blockquote style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;" class="gmail_quote">After thinking about this, I am not really sure that I want to change the<br>


name &quot;Image&quot;, though. You should not use java.awt.Image and<br>
mpicbg.imglib.image.Image in the same class to begin with.<br></blockquote>
<br>I do not think it is good to say &quot;you should not&quot; in cases like this. We don&#39;t know everything people are going to be doing with these classes. If someone writes a java.awt.Image -&gt; mpicbg.imglib.image.Image converter, for example, they will surely end up with at least one class referencing both classes.<br>

<br><blockquote style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;" class="gmail_quote">
And in a sense, they _do_ mean the same. It&#39;s just that AWT is limited to<br>
2 dimensions, why imglib isn&#39;t.<br></blockquote>
<br>Sure. For me it a purely practical concern of two classes with the same name clashing.<br><br><blockquote style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;" class="gmail_quote">


I do not like ImageSpace, though. It contradicts my perception of what the<br>
class is about.<br></blockquote><br>I don&#39;t really like it either. How about &quot;Img&quot; mirroring the &quot;img&quot; in &quot;imglib&quot;? Kind of ugly but at least it&#39;s unique. Otherwise we could use &quot;IImage&quot; or &quot;NDImage&quot; or &quot;ILImage&quot; or &quot;HyperImage&quot;...<br>

<br>-Curtis<br><br><div class="gmail_quote">On Mon, Oct 11, 2010 at 12:32 PM, Johannes Schindelin <span dir="ltr">&lt;<a href="mailto:Johannes.Schindelin@gmx.de">Johannes.Schindelin@gmx.de</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">

Hi,<br>
<div class="im"><br>
On Mon, 11 Oct 2010, Curtis Rueden wrote:<br>
<br>
&gt; I agree with Grant. If the design is going to change and break existing<br>
&gt; code—which I think is fine at this stage—I would like to see a different<br>
&gt; name than &quot;Image&quot; to avoid clashing with java.awt.Image.<br>
<br>
</div>Yes, I agree that nomenclature might be something we want to change,<br>
but...<br>
<br>
&gt; &gt; &quot;MultidimensionalImageDataBufferLikeThingThatIsNotReallyAnImage&quot; ??<br>
<br>
... Grant, you&#39;re not German enough to be entitled to suggest such a<br>
variable name :-)<br>
<br>
I do not like ImageSpace, though. It contradicts my perception of what the<br>
class is about.<br>
<br>
After thinking about this, I am not really sure that I want to change the<br>
name &quot;Image&quot;, though. You should not use java.awt.Image and<br>
mpicbg.imglib.image.Image in the same class to begin with.<br>
<br>
And in a sense, they _do_ mean the same. It&#39;s just that AWT is limited to<br>
2 dimensions, why imglib isn&#39;t.<br>
<br>
There are other class names I&#39;d love to see changed, but &quot;Image&quot; is not<br>
one of them.<br>
<br>
Ciao,<br>
<font color="#888888">Johannes<br>
</font></blockquote></div><br>